In order to successfully use the ADP, your computer must meet the following minimum requirements (revised: August 2021):


Supported desktop web browsers

  • Google Chrome 89 or newer*
  • Mozilla Firefox 78 or newer*
  • Microsoft Edge 89 or newer*
  • Opera 75 or newer*
  • Apple Safari 14 or newer

* For web browsers with a rapid release cycle, including Edge, Chrome, Firefox, and Opera, please use the latest supported version from the browser manufacturer.

NOTE: Internet Explorer 11 support ended in June 2022.


Supported desktop operating systems

  • Windows 8.1 or newer
  • MacOS 11.3 or newer
  • Distributions of Linux that support the aforementioned browsers


Supported mobile/tablet configurations

  • iOS 12 or newer (tested in Safari, Chrome, and Firefox web browsers)
  • Android 8.0 (Oreo) or newer* (tested in Chrome and Firefox web browsers)

* NOTE: Due to the large variety of Android devices, it is possible that certain untested device configurations may exhibit unexpected symptoms. If you encounter problems, please contact ADP Technical Support with information about your device (make/model, browser, and version of Android OS). If you experience extended issues on your device, we recommend using a desktop computer.


Additional requirements:

  • Adobe Reader DC or newer on Windows and MacOS, or other compatible PDF viewer software (to view/print certificates and invoices)
  • Your browser must accept "cookies" to complete the registration process and to log into the site.
  • For desktop computers, we recommend your monitor support a resolution of at least 1280 pixels wide, and at least 720 pixels tall.

NOTE: Some firewall software has been known to interfere with connectivity to the ADP. If you experience trouble connecting, but can still connect to other Internet sites, please try disabling the firewall software, or adding the iatfadp.com domain to the firewall's exception list.


Additional requirements for Live Virtual Proctoring: